Aide Excel

Forum d'aide et d'entraide sur Excel : cours, astuces, tutoriaux...
 
AccueilPortailFAQRechercherS'enregistrerMembresGroupesConnexion

Partagez | 
 

 Comment calculer l'ancienneté du personnel

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
solys63
Membre


Nombre de messages : 3
Date d'inscription : 13/06/2012

MessageSujet: Comment calculer l'ancienneté du personnel    Mer 13 Juin à 12:05

Bonjour Coucou ,

Je dois faire un tableau qui calcule l'ancienneté du personnel dans l'entreprise pour 2010 - 2011 - 2012
J'ai inséré dans ce tableau la date d'entrée et date de sortie des salariés.

J'ai inséré une formule mais elle calcule à partir de la date d'entrée avec la date du jour et ne prends pas en compte la date de sortie de ceux qui ne travaillent plus chez nous.
Mon tableau est donc faux mais je ne vois pas comment faire parce que lorsque je mets la date d'entrée - la date de sortie dans ma formule de base ça ne marche plus.

Et mon deuxième soucis c'est pour calculer l'effectif en 2010 et 2011

Est ce qu'il y a un moyen de vous envoyer mon fichier excel sur le forum?

Spoiler:
 
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Erkios
Membre


Nombre de messages : 4
Date d'inscription : 19/06/2012

MessageSujet: Re: Comment calculer l'ancienneté du personnel    Mar 19 Juin à 14:06

Salut,

Je te conseille de faire comme ça :

A1 : Nom du salarié
B1 : Date d'entrée
C1 : Date de sortie
D1 : Ancienneté

La formule a entrer dans la cellule D2 et a étendre est la suivante :

Code:
=SI(C2="";AUJOURDHUI()-B2;C2-B2)

Cela te donnera le nombre de jours passés dans l'entreprise depuis la date d'entrée jusque la date de sortie le cas échéant, sinon, le nombre de jours depuis l'arrivée jusque la date de consultation du tableau.

Pour l'effectif, je pense que tu devrais opter pour un tableau croisé dynamique.

Bonne continuation.

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
solys63
Membre


Nombre de messages : 3
Date d'inscription : 13/06/2012

MessageSujet: Re: Comment calculer l'ancienneté du personnel    Mar 19 Juin à 17:18

Erkios a écrit:
Salut,

Je te conseille de faire comme ça :

A1 : Nom du salarié
B1 : Date d'entrée
C1 : Date de sortie
D1 : Ancienneté

La formule a entrer dans la cellule D2 et a étendre est la suivante :

Code:
=SI(C2="";AUJOURDHUI()-B2;C2-B2)

Cela te donnera le nombre de jours passés dans l'entreprise depuis la date d'entrée jusque la date de sortie le cas échéant, sinon, le nombre de jours depuis l'arrivée jusque la date de consultation du tableau.

Pour l'effectif, je pense que tu devrais opter pour un tableau croisé dynamique.

Bonne continuation.


Bonjour Coucou ,

Tout d'abord merci de ta réponse. Je suis en crise avec ce tableau, je m'arrache les cheveux.
Par contre y a t'il un moyen d'avoir le résultat en nombre d'années au lieu du nombre de jours? Mon tableau d'effectif classe mes personnes par tranches d'années d'ancienneté et du coup ça ne fonctionnera pas si j'ai des jours d'un côté et des années de l'autre.

Pour la suite ça va je suis pas bloquée, j'ai du faire un tri par tranche d'âge pour une pyramide des âges et du coup je prendrai la même formule à quelque chose près pour l'ancienneté. (sauf si je me rends compte que ça fonctionne pas Laughing )
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Erkios
Membre


Nombre de messages : 4
Date d'inscription : 19/06/2012

MessageSujet: Re: Comment calculer l'ancienneté du personnel    Mer 20 Juin à 9:57

Salut,

Désolé j'ai pas le temps d'envisager toutes les options, j'vais donc te demander des précisions.

Tu veux connaître le nombre d'années passées dans l'entreprise, mais par exemple, un mec arrivé le 12/12/2010 et parti le 03/01/2012, tu considères qu'il a passé 2 ou 3 ans dans l'entreprise ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
solys63
Membre


Nombre de messages : 3
Date d'inscription : 13/06/2012

MessageSujet: Re: Comment calculer l'ancienneté du personnel    Mer 20 Juin à 12:07

Erkios a écrit:
Salut,

Désolé j'ai pas le temps d'envisager toutes les options, j'vais donc te demander des précisions.

Tu veux connaître le nombre d'années passées dans l'entreprise, mais par exemple, un mec arrivé le 12/12/2010 et parti le 03/01/2012, tu considères qu'il a passé 2 ou 3 ans dans l'entreprise ?

En fait pour ton exemple la personne à passé 1 ans dans l'entreprise et s'il était pas sorti il faudrait que mon calcul donne un résultat de 1 ans jusqu'à ce que la date du jour arrive au 12/12/2012 et que le résultat passe automatiquement à 2 ans.

Je sais pas si je suis claire en fait scratch
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Comment calculer l'ancienneté du personnel    

Revenir en haut Aller en bas
 
Comment calculer l'ancienneté du personnel
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Comment calculer l'heure TU à partir de l'heure système ?
» Calculer un point GPS a partir d'une carte routière papier
» Comment calculer sa taille de soutien-gorge ?
» Calcul de dénivelé par Memory Map
» tableau de calcul ?

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Aide Excel :: Entraide & apprentissage :: A l'aide...-
Sauter vers: