Aide Excel

Forum d'aide et d'entraide sur Excel : cours, astuces, tutoriaux...
 
AccueilPortailFAQRechercherS'enregistrerMembresGroupesConnexion

Partagez | 
 

 Formule RechercheV

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Juliane
Membre


Nombre de messages : 1
Date d'inscription : 20/09/2010

MessageSujet: Formule RechercheV   Lun 20 Sep à 13:13

Bonjour à tous,

J'me permets de sollicitée votre aide pour un problème pro auquel je n'ai pas encore trouver une solution : je vais essayer d'etre la plus claire possible.

Je cherche à utiliser la formule Recherchev ( sur une feuille) pour recherche une quantité associée a un code dans un tableau (qui est sur un autre feuille) :

=CERCA.VERT(A6,'1'!$A$11:$L$40,12)

CERCA.VERT n'est pas une erreur : je bosse en italie, comprendre RECHERCHEV.
A6 est la cellule ou ce trouve le code que je recherche dans l'autre feuille (ici A6=1a)
'1'!$A$11:$L$40 : 1 est le nom de feuille ou se trouve le tableau dans lequel je recherche la valeur, et evidement A11:L40 est le tableau.
12 : numero de la colonne ou se trouve la valeur que je veux associer au code 1a.

D'une part, voyez vous une erreur dans la formule ( jsuis plutot du coté "débutante" en excell), parce que dans mon exemple, excel doit me renvoyer la valeur 0, il n'y a pas, dans l'exemple de cas de code 1a) ) d'autre part, je me demande si c'est bien cette formule qui la plus appropriée à mon problème ? Sinon, quelle formule utiliser ?


Merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dachevid
Membre


Nombre de messages : 275
Date d'inscription : 05/09/2005

MessageSujet: Re: Formule RechercheV   Mar 21 Sep à 15:54

Bonjour,

La formule me semble bonne vu les explications, mais il faut que le tableau en feuille 1 soit trié en ordre croissant dans la colonne A.
Si ce n'est pas le cas c'est pour ça que la formule ne marche pas. Tu cherches une valeur exacte (la quantité pour le code a1) donc tu dois ajouter un argument à la recherche verticale, l'argument 'valeur proche'.
Il doit contenir FAUX car tu ne cherches pas une valeur approchante (par exemple l'âge d'une personne qui a 22 ans est compris dans l'intervalle 20/30 ou 20/25) mais une valeur exacte (exactement le code a1), en France ça donnerait ça :
=RECHERCHEV(A6 ; '1'!$A$11:$L$40 ; 12 ; FAUX)

En Italie c'est peut-être ça :
=CERCA.VERT(A6,'1'!$A$11:$L$40,12,FALSO) (Avec des "," au lieu de ";" ??)

Cela dit Excel ne renverra pas non plus 0 dans ce cas, il renverra #NA!. Le 0 que tu as doit être la quantité d'un autre code proche alphabétiquement de a1 et situé plus en haut du tableau de la feuille 1.

Pour éviter les erreurs il faut utiliser un SI (SE en Italien ?) pour vérifier si a1 existe et sinon ne rien afficher plutôt qu'une erreur.
=SI(ESTNA(RECHERCHEV(A6;'1'!$A$11:$L$40;12;FAUX));"";RECHERCHEV(A6;'1'!$A$11:$L$40;12;FAUX))
ou
=SI(ESTNA(RECHERCHEV(A6;'1'!$A$11:$L$40;12;FAUX));"Code inconnu en colonne A";RECHERCHEV(A6;'1'!$A$11:$L$40;12;FAUX))

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
 
Formule RechercheV
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Nouvelle Formule Carte 24/24 illimité à 20€ par mois
» formule mathématique
» Renault - Formule 1 Grand Prix d’Europe 2016
» Quelle OS utilisé
» PANOMAND : pour explorer l'ensemble de Mandelbrot

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Aide Excel :: Entraide & apprentissage :: A l'aide...-
Sauter vers: