Aide Excel

Forum d'aide et d'entraide sur Excel : cours, astuces, tutoriaux...
 
AccueilPortailFAQRechercherS'enregistrerMembresGroupesConnexion

Partagez
 

 problème formule/résolu

Aller en bas 
AuteurMessage
11gsxr
Membre


Nombre de messages : 3
Date d'inscription : 06/06/2010

problème formule/résolu Empty
MessageSujet: problème formule/résolu   problème formule/résolu EmptyDim 6 Juin à 19:58

bonjour
je voudrais que A2 soit égal a A1 si je met 1 dans A2 et que A2 soit égal a zéro si je met 0 dans A2(je pense que c'est grâce à la fonction "si" mais je ne trouve pas la bonne formule).
merci d'avance


Dernière édition par 11gsxr le Lun 21 Juin à 23:54, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dachevid
Membre


Nombre de messages : 275
Date d'inscription : 05/09/2005

problème formule/résolu Empty
MessageSujet: Re: problème formule/résolu   problème formule/résolu EmptyLun 7 Juin à 11:28

Bonjour,

Je crois qu'il y a une erreur dans l'ennoncé :
"je voudrais que A2 soit égal a A1 si je met 1 dans A2 et que A2 soit égal a zéro si je met 0 dans A2", je suppose qu'il faut comprendre A1.

En A2 mettre cette formule :
=SI(A1=1;1;0)

Mais le plus simple reste en A2 :
=A1

Tu n'as pas indiqué s'il y avait d'autres cas que 0 et 1.

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
11gsxr
Membre


Nombre de messages : 3
Date d'inscription : 06/06/2010

problème formule/résolu Empty
MessageSujet: Re: problème formule/résolu   problème formule/résolu EmptyLun 7 Juin à 22:12

bonjour et merci de ta réponse.
en fait il n'y a pas d'erreur.je m'explique.
c'est pour un tableau binaire.
A1=128 B1=64.......H1=1
si je rentre le chiffre 1 dans A2 alors A2 =A1(donc 128)
si je rentre le chiffre 0 dans A2 alors A2=0
j'adapte la formule pour B2,C2,.....H2
ensuite je fais somme automatique dans I2(A2+B2+C2....H2)
et cela devrait me changer mon binaire(ex:00010110)en22
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dachevid
Membre


Nombre de messages : 275
Date d'inscription : 05/09/2005

problème formule/résolu Empty
MessageSujet: Re: problème formule/résolu   problème formule/résolu EmptyLun 21 Juin à 15:40

Re,

Ok je comprends mieux.

En I2 : =A2&B2&C2&D2&E2&F2&G2&H2
En I2 je mets un format de cellule personnalisé 00000000 pour avoir toujours 8 chiffres : 00010110
Tu peux utiliser =BINDEC(I2), convertit un binaire en décimale, tu obtiens 22.

Sinon il y a aussi =SOMME.SI(A2:H2;1;A1:H1)
Si en A2:H2 il y a un 1 alors on fait la somme des chiffres en A1:H1 donc 16 + 4 + 2 = 22.

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
11gsxr
Membre


Nombre de messages : 3
Date d'inscription : 06/06/2010

problème formule/résolu Empty
MessageSujet: Re: problème formule/résolu   problème formule/résolu EmptyLun 21 Juin à 23:53

bonjour et merci bien.
la solution n°2 est exactement ce que je cherchais.
je viens de tester et cela fonctionne parfaitement.
encore merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




problème formule/résolu Empty
MessageSujet: Re: problème formule/résolu   problème formule/résolu Empty

Revenir en haut Aller en bas
 
problème formule/résolu
Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Aide Excel :: Entraide & apprentissage :: A l'aide...-
Sauter vers: