Aide Excel

Forum d'aide et d'entraide sur Excel : cours, astuces, tutoriaux...
 
AccueilPortailFAQRechercherS'enregistrerMembresGroupesConnexion

Partagez | 
 

 CNUM et fractions

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Vhalar
Membre


Nombre de messages : 4
Date d'inscription : 29/03/2010

MessageSujet: CNUM et fractions   Mer 28 Avr à 9:34

Bonjour,

Je cherche à entrer dans une cellule au format texte des informations de type:

1
1/2
1 1/2
etc

Pour récupérer dans une autre cellule respectivement les valeurs suivantes:

1
0.5
1.5

J'ai donc fait un CNUM de ma cellule au format texte.

1 renvoie bien 1
1 1/2 renvoie bien 1.5
Mais 1/2 revoie 40210 !!

De même pour toutes les fractions de type x/y

Comment remédier à ce problème?

(ps: c'est volontaire si je n'utilise pas le format de cellule fraction)

Merci d'avance.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dachevid
Membre


Nombre de messages : 275
Date d'inscription : 05/09/2005

MessageSujet: Re: CNUM et fractions   Ven 30 Avr à 14:53

Bonjour,

40210 correspond au 1/2/2010, idem pour les autres fractions.

Je n'ai pas trouvé de solution avec une fonction si ce n'est de taper 0 1/2 au lieu de 1/2.

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Vhalar
Membre


Nombre de messages : 4
Date d'inscription : 29/03/2010

MessageSujet: Re: CNUM et fractions   Mer 5 Mai à 17:17

Bonjour,

Ta réponse m'a bien aidé.

Pour remédier au problème, je place une condition: si le nombre de caractère de la cellule à traiter est égal à 3, alors je fais le CNUM de ma cellule en lui rajoutant "0 ", sinon je fais un simple CNUM

Ca donne ça:

=SI(NBCAR(E4)=3;CNUM("0 "&E4);CNUM(E4))

Merci !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: CNUM et fractions   

Revenir en haut Aller en bas
 
CNUM et fractions
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Aide Excel :: Entraide & apprentissage :: A l'aide...-
Sauter vers: