Aide Excel

Forum d'aide et d'entraide sur Excel : cours, astuces, tutoriaux...
 
AccueilPortailFAQRechercherS'enregistrerMembresGroupesConnexion

Partagez | 
 

 exécuter un calcul si deux colonnes comportent des chiffres

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
accingege
Membre


Nombre de messages : 1
Date d'inscription : 14/01/2010

MessageSujet: exécuter un calcul si deux colonnes comportent des chiffres   Jeu 14 Jan à 19:54

Bonjour à tous ,

je souhaiterais exécuter un calcul dans une colonne seulement si les deux colonnes suivantes comportent les nombres à additionner , sinon cette première colonne devrait rester vide.
Qui pourrait m'aider S.V.P

merci d'avance .
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dachevid
Membre


Nombre de messages : 275
Date d'inscription : 05/09/2005

MessageSujet: Re: exécuter un calcul si deux colonnes comportent des chiffres   Ven 15 Jan à 0:19

Bonsoir,

Si les chiffres se trouvent en B2 et C2 :
=SI(ET(B2<>"";C2<>"");B2+C2;"")
Si B2 et C2 ne sont pas vides, alors on calcule B2 + C2 sinon on laisse la cellule vide.

Par contre si les nombres à additionner sont particuliers, par exemple seulement s'il y a un nombre entre 10 et 20, la formule est complétement différente.

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dachevid
Membre


Nombre de messages : 275
Date d'inscription : 05/09/2005

MessageSujet: Re: exécuter un calcul si deux colonnes comportent des chiffres   Ven 15 Jan à 18:21

Pour ton cas avec des chiffres à additionner si saisie en A2 ou soustraire si saisie en C2, inscrire en B2 :
=SI(A2<>"";A1+A2;SI(C2<>"";A1-C2;""))

Si les deux sont vides B2 reste vide.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: exécuter un calcul si deux colonnes comportent des chiffres   

Revenir en haut Aller en bas
 
exécuter un calcul si deux colonnes comportent des chiffres
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» ANIMATION
» Un Qeel en deux colonnes
» [Résolu] addition de deux variable.
» j'ai deux question qui m'intrigue
» Calcul de dénivelé par Memory Map

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Aide Excel :: Entraide & apprentissage :: A l'aide...-
Sauter vers: