Aide Excel

Forum d'aide et d'entraide sur Excel : cours, astuces, tutoriaux...
 
AccueilPortailFAQRechercherS'enregistrerMembresGroupesConnexion

Partagez | 
 

 remplacer des casse automatiquement grâce a des réf:

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
eti_57
Membre


Nombre de messages : 1
Date d'inscription : 08/10/2009

MessageSujet: remplacer des casse automatiquement grâce a des réf:   Jeu 8 Oct à 13:45

bonjour

Je voudrais savoir comment je pourrais faire pour avoir grâce a une référence les casse qui se remplisse automatiquement je m explique mieux

ex:

j ai des colonne :
réf
désignation
prix ttc
prix ht

et je voudrais savoir comment je pourrais faire pour que si je tape ma référence les autre colonne se remplisse automatiquement

pour précision mais réf et toute les autre donnée sont sur une autre feuille de excel

merci de votre aide
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dachevid
Membre


Nombre de messages : 275
Date d'inscription : 05/09/2005

MessageSujet: Re: remplacer des casse automatiquement grâce a des réf:   Lun 12 Oct à 16:18

Bonjour,

Question souvent posée sur ce forum et sur d'autres : il faut utiliser la fonction RECHERCHEV.

Exemple :

Il faut un tableau qui va servir de base de travail qui contient les références (obligatoirement en première colonne) puis les autres : désingnation, prix ttc et prix HT.
Imaginons ce tableau en feuille Feuil1 de A1 à D50.
Chaque référence ne doit figurer qu'une seule fois.

Sur un deuxième tableau je saisis en B10 une référence et je veux en C10 la désignation.
C10 :
=RECHERCHEV(B10;Feuil1!$A$2:$D$50;2;faux)

On va récupérer la valeur en B10 puis la rechercher en Feuil1 à partir de A2 (A1 contient le titre "Références"), une fois qu'Excel l'a trouvée en colonne A je lui indique que je veux la deuxième colonne (soit la colonne B de mon tableau en Feuil1) pour récupérer la désignation, 3 permettrait de récupérer le prix TTC, etc.
FAUX indique qu'on cherche une référence fixe (l'article Vis14 s'appelle Vis14 et pas autrement) et pas un intervalle de référence, ainsi si je tape Vis15 et que cette référence n'existe pas il affichera une erreur plutôt que de récupérer la valeur de Vis14.

Recopier la formule sur le tableau, en n'oubliant pas les $ dans la première formule.
Et voilà !!

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
 
remplacer des casse automatiquement grâce a des réf:
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Remplacer automatiquement toutes les expressions par une image et un lien
» Quel Garmin aujourd'hui pour remplacer le 278C?
» Remplacer la tête des boutons des basses !!
» Remplacer le Portail par une image réactive
» Code css pour marges et pour justifier un message automatiquement

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Aide Excel :: Entraide & apprentissage :: A l'aide...-
Sauter vers: