Aide Excel

Forum d'aide et d'entraide sur Excel : cours, astuces, tutoriaux...
 
AccueilPortailFAQRechercherS'enregistrerMembresGroupesConnexion

Partagez | 
 

 [Résolu]Convertir aussi bien 731 en 07:31 et 1031 en 10:31

Aller en bas 
AuteurMessage
Kiriko
Membre


Nombre de messages : 2
Date d'inscription : 20/09/2009

MessageSujet: [Résolu]Convertir aussi bien 731 en 07:31 et 1031 en 10:31   Dim 20 Sep à 23:56

Bonjour et merci de vous pencher sur mon problème.
Je souhaite convertir des nombres d'une colonne qui comportent soit 3 chiffres, soit 4 en heure. Mais "textuellement", c'est à dire que 731 doit devenir 7:31 (ou 07:31 c'est égal) et que 1031 doit devenir 10:31.
Je deviens fou à essayer de chercher, les seules réponses que je trouve sont du type convertir 3,5 vers 3:30 mais ce n'est pas du tout ce que je recherche.....


Dernière édition par Kiriko le Lun 21 Sep à 17:11, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dachevid
Membre


Nombre de messages : 275
Date d'inscription : 05/09/2005

MessageSujet: Re: [Résolu]Convertir aussi bien 731 en 07:31 et 1031 en 10:31   Lun 21 Sep à 16:59

Bonjour,

J'ai 731 en A1.
En B1 :
=(ENT(A1/100)+((A1/100)-ENT(A1/100))*100/60)/24

Je divise le nombre par 100 (7,31) puis je ne récupère que les décimales (le nombre 7,31 moins le nombre entier 7 donc 0,31). Je le multiplie par 100 et divise par 60 pour obtenir un centième d'heure et non pas un soixantième, 0,31 devient environ 0,51 soit plus de la moitié d'une heure.
Ensuite je lui ajoute 7 (le nombre entier de A1/100) pour obtenir 7,51, on divise le tout par 24 car on veut le résultat en heure et pas en nombre, il n'y a plus qu'à modifier le résultat à l'aide d'un format Heure et on obtient 7:31.

On doit pouvoir simplifier ce calcul mais pas le temps... !!!

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Kiriko
Membre


Nombre de messages : 2
Date d'inscription : 20/09/2009

MessageSujet: Re: [Résolu]Convertir aussi bien 731 en 07:31 et 1031 en 10:31   Lun 21 Sep à 17:10

Merci beaucoup, ça marche impeccable. Et surtout merci pour l'explication détaillée, formatrice....

Je viens de trouver 2 alternatives aussi efficaces :

=TEXTE(GAUCHE(TEXTE(A1;"0000");2)&":"&DROITE(TEXTE(A1;"0000");2);"hh:mm")

ou encore :

=SUBSTITUE(TEXTE(A1/100;"0,00");",";":")*1
Merci à toi dachevid
et aussi à thibo et à Amadéus d' excel-pratique.

C'est la magie des formules d'excel et que je découvre.... J'adore....
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: [Résolu]Convertir aussi bien 731 en 07:31 et 1031 en 10:31   

Revenir en haut Aller en bas
 
[Résolu]Convertir aussi bien 731 en 07:31 et 1031 en 10:31
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [ Résolu ] convertir un fichier .M4V en AVI
» [résolu]Moi aussi probleme avec : www.search-web.net/ Sorry.
» Choix nouveau GPS
» [ résolu ]Comment convertir des fichiers EPS
» [résolu]pc infecté par wwwzuc32.exe

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Aide Excel :: Entraide & apprentissage :: A l'aide...-
Sauter vers: