Aide Excel

Forum d'aide et d'entraide sur Excel : cours, astuces, tutoriaux...
 
AccueilPortailFAQRechercherS'enregistrerMembresGroupesConnexion

Partagez | 
 

 PAIR - IMPAIR

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
LDH
Membre


Nombre de messages : 14
Date d'inscription : 21/07/2008

MessageSujet: PAIR - IMPAIR   Jeu 17 Sep à 22:12

Bonjour,
Dans une colonne d'un fichier Excel,j'ai des nombres pair et impair.J'aimerais savoir s'il existe une formule pour déterminer le nombre de cellules contenant des nombres pairs et le nombre de cellules contenant des nombres impairs. Merci
Hervé
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dachevid
Membre


Nombre de messages : 275
Date d'inscription : 05/09/2005

MessageSujet: Re: PAIR - IMPAIR   Lun 21 Sep à 17:27

Bonjour,

Les nombres sont en colonne A.

Pour calculer le nombre d'impairs :
{=SOMME(SI(A1:A100=IMPAIR(A1:A100);1;0))}

Attention les {} s'obtiennent en saisissant la formule =SOMME(SI(A1:A100=IMPAIR(A1:A100);1;0)) puis en validant par CTRL+MAJ+ENTREE.

On peut bien sûr remplacer 100 par une autre valeur mais toujours valider par CTRL+MAJ+ENTREE.

Pour les nombres pairs c'est pareil avec la fonction PAIR (*) ou alors =NB(A:A)-C1. En C1 j'ai la formule des nombres impairs.

(*) Attention pour les nombres pairs si on compte jusqu'à A100 et qu'il y a des cellules vides (donc égales à 0) 0 est considéré comme pair.

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
LDH
Membre


Nombre de messages : 14
Date d'inscription : 21/07/2008

MessageSujet: Re: PAIR - IMPAIR   Ven 25 Sep à 18:16

Bonjour Dachevid et merci pour votre collaboration.
Hervé
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
LDH
Membre


Nombre de messages : 14
Date d'inscription : 21/07/2008

MessageSujet: PAIR IMPAIR   Ven 25 Sep à 19:57

Rebonjour Dachevid,
En fait ,j'ai un petit souci,la formule ne marche.Peut être à cause de la version Excel (2000)?
Hervé
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dachevid
Membre


Nombre de messages : 275
Date d'inscription : 05/09/2005

MessageSujet: Re: PAIR - IMPAIR   Lun 19 Oct à 15:09

Rebonjour LDH,

Chez moi en Excel 2000 cette formule fonctionne ! As-tu bien validé par Control, Majuscule et Entrée en même temps.

Bon ce n'est pas grave car je te propose une variante :
=SOMMEPROD((IMPAIR(A1:A100)=A1:A100)*1) pour compter le nombre de cellules contenant un chiffre impair.

=SOMMEPROD((PAIR(A1:A100)=A1:A100)*(A1:A100<>"")) pour les nombres pairs. Comme pour l'autre formule avec {Somme(Si(...))} les cellules vides jusqu'à A100 sont considérées comme paires donc avec A1:A100<>"" on élimine le problème en ne prenant que les cellules non vides, celles qui contiennent 0 sont considérées comme paires.

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
LDH
Membre


Nombre de messages : 14
Date d'inscription : 21/07/2008

MessageSujet: Re: PAIR - IMPAIR   Jeu 22 Oct à 18:31

Bonjour Dachevid,
En fait une personne m'a donné de l'aide et il existe une fonction dediée à cela. Il faut dans Outils - Macro complémentaires,cocher les cases de la fenêtre "Macro Complémentaires disponibles". Puis on trouve les 2 fonctions Est.Pair et Est.Impair dans la catégorie "Information"
Ex: =SI(EST.PAIR(A100);A100;0).Voilà si ca peut intérresser quelqu'un.
Merci Dachevid pour ton amabilité
Hervé
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: PAIR - IMPAIR   

Revenir en haut Aller en bas
 
PAIR - IMPAIR
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Pair et Impair

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Aide Excel :: Entraide & apprentissage :: A l'aide...-
Sauter vers: