Aide Excel

Forum d'aide et d'entraide sur Excel : cours, astuces, tutoriaux...
 
AccueilPortailFAQRechercherS'enregistrerMembresGroupesConnexion

Partagez | 
 

 Somme si mais avec un autre critère de date ...

Aller en bas 
AuteurMessage
lolo40lm
Membre


Nombre de messages : 1
Date d'inscription : 15/04/2009

MessageSujet: Somme si mais avec un autre critère de date ...   Lun 10 Aoû à 23:18

Oui
Bonjour, je viens de comprendre la fonction somme.si. qui est très pratique mais est il possible de rajouter un autre critère : la date ?
Je vous explique, je veux juste savoir quel est le montant dépensé par mois dans mon budget familial.
Aussi, existe t'il une fonction que me permette de calculer une moyenne mais uniquement sur des cellules renseignées et non la plage complète qui contient des "blancs" ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dachevid
Membre


Nombre de messages : 275
Date d'inscription : 05/09/2005

MessageSujet: Re: Somme si mais avec un autre critère de date ...   Mer 23 Sep à 17:20

Bonjour,

Le mieux est certainement d'utiliser un tableau croisé dynamique plutôt que SOMME.SI.
Tu pourras ainsi avoir tous les mois automatiquement.
Si tu veux vraiment utiliser SOMME.SI il vaut mieux passer par l'assistant Somme conditionnelle, s'il n'est pas présent dans le menu Outils il faut l'ajouter par Outils - Macros complémentaires... et cocher Assistant somme conditionnelle.

Tu obtiendras une formule du style :
{=SOMME(SI($A$2:$A$16>=DATEVAL("01/09/2009");SI($A$2:$A$16<=DATEVAL("30/09/2009");$B$2:$B$16;0);0))}
pour un calcul sur le mois de septembre.
A2:A16 contient les dates, B2:B16 les montants.

Attention il faut laisser les accolades {}, c'est un calcul matriciel car les SI font un test logique sur plusieurs cellules. Toujours valider les modifications par CTRL+MAJ+ENTREE pour conserver les {}
MAJ = SHIFT, c'est la touche au-dessus de Control CTRL et pas le verrouillage majuscules.
Il s'agit d'une somme et d'un si, pas de somme.si.

On peut la simplifier ainsi :
{=SOMME(SI(MOIS($A$2:$A$16)=9;$B$2:$B$16;0))}
car septembre = 9 mais attention j'ai un tableau avec uniquement l'an 2009, s'il y a des valeurs en septembre 2008 elles seront incluses dans la somme !

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dachevid
Membre


Nombre de messages : 275
Date d'inscription : 05/09/2005

MessageSujet: Re: Somme si mais avec un autre critère de date ...   Mer 23 Sep à 17:26

Concernant la deuxième question, les blancs sont-ils des cellules vides ou contenant 0 ou "" ?
Si c'est vide ou égal à "", la moyenne ignore ces cellules.

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Somme si mais avec un autre critère de date ...   

Revenir en haut Aller en bas
 
Somme si mais avec un autre critère de date ...
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Problème avec un autre forum
» Cacher une image avec une autre image
» Domaine Personnalisé avec un autre hébergement: configuration par IP !?
» probleme avec un autre forum
» De l'image, mais pas de son

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Aide Excel :: Entraide & apprentissage :: A l'aide...-
Sauter vers: