Aide Excel

Forum d'aide et d'entraide sur Excel : cours, astuces, tutoriaux...
 
AccueilPortailFAQRechercherS'enregistrerMembresGroupesConnexion

Partagez | 
 

 Aide sur renvoi valeur dans une cellule

Aller en bas 
AuteurMessage
f1ralfy
Membre


Nombre de messages : 2
Date d'inscription : 15/05/2008

MessageSujet: Aide sur renvoi valeur dans une cellule   Jeu 15 Mai à 17:48

Bonjour à tous,

J'ai un tableau avec des articles référencés et leurs prix.
Dans un autre tableau, j'ai ces mêmes articles référencés mais avec la quantité en stock.

Comment fait on pour copier la quantité en stock dans le premier fichier en regard du bon article.

d'avance merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
dachevid
Membre


Nombre de messages : 275
Date d'inscription : 05/09/2005

MessageSujet: Re: Aide sur renvoi valeur dans une cellule   Jeu 15 Mai à 18:10

Bonjour,

Il faut faire une recherche verticale puis un copier/collage spécial des valeurs.

Soit mon tableau en feuille Feuil1 avec en colonne A la référence et en B le prix.
En feuille Feuil2 j'ai les références en A et le stock en B, si c'est l'inverse il suffit de faire un copier coller car il faut absolument les références avant le stock. Ma liste va de A1 à B100 avec les titres en ligne 1.

En feuille Feuil1 sur la colonne C mettre cette formule, en C2 :
=RECHERCHEV(A2;Feuil2!$A$2:$B$100;2;faux)
On récupère la référence en A2, puis dans la feuille Feuil2 on va chercher cette référence dans la première colonne (A) du tableau $A$2:$A$100 (bien mettre les $ car on va recopier la formule) en feuille Feuil2, une fois qu'Excel l'a trouvée il récupère le stock en colonne 2 (la colonne B) et l'affiche en C2. Recopier la formule en feuille Feuil1 sur toute la hauteur du tableau.
Pour ne conserver que les chiffres et pas la formule, sélectionner la colonne C, copier puis Edition-Collage spécial..., choisir Valeurs et valider. On a ainsi le stock sous forme de nombre et plus de formule, on peut supprimer Feuil2.

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
f1ralfy
Membre


Nombre de messages : 2
Date d'inscription : 15/05/2008

MessageSujet: Re: Aide sur renvoi valeur dans une cellule   Jeu 15 Mai à 21:10

merci beaucoup pour la réponse et en plus rapide
A bientôt
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Aide sur renvoi valeur dans une cellule   

Revenir en haut Aller en bas
 
Aide sur renvoi valeur dans une cellule
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Aide css couleurs (introuvable dans le panel)
» Mettre l'image des forums en haut, non centrée dans la cellule
» remplacer la couleur dans la cellule de message par une image
» Bibliothèque de sous-programmes
» Définir un texte en couleur dans une cellule excel

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Aide Excel :: Entraide & apprentissage :: Cours et astuces-
Sauter vers: